注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

心情挺好的博客

正在等你光临呢 呵呵

 
 
 

日志

 
 
关于我

喜欢摄影的朋友看过来:) 有时间就跟我一起去拍照去吧. QQ272751 上海圣玛丽摄影化妆培训学校 16年专业摄影培训化妆培训学校 电话:15900513500。 http://www.smlsh.com

网易考拉推荐

OpenWrt Webcam on Asus WL500G  

2009-01-13 13:59:41|  分类: 技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

OpenWrt

Wireless Freedom

You are not logged in.

Announcement

Latest: 7.09. Please read before posting -
Forum Rules | Common mistakes | Documentation | Faq | Bug reports

Pages: 1

 

#1 2005-07-08 22:57:26

http://forum.openwrt.org/viewtopic.php?id=1966
albi
Member

Registered: 2005-06-12
Posts: 3

Webcam on Asus WL500G

Is it possible to use a webcam on wl500g with openwrt?


ALBI...

Offline

 

#2 2005-07-09 14:53:01

olli
Former developer

Registered: 2005-03-28
Posts: 531

Re: Webcam on Asus WL500G

You can, if you modify the firmware.

I think currently only usb-printers and usb-storage is supported.


Olli has since left the OpenWrt project; these posts remain for historical reasons.

Offline

 

#3 2007-02-11 23:58:17

prabhu_g
Member

Registered: 2007-02-11
Posts: 3

Re: Webcam on Asus WL500G

Hi,

I am using ASUS wl500gp , openwrt-brcm-2.4-squashfs.trx on it.
I am trying to get jpg image from a logitech quickcam IM.
(vend/prod 0x46d/0x8a6) and tried the steps from
http://www.macsat.com/macsat/content/view/36/30/
I even tried all the usb drivers like uhci,ehci&ohci.

i could not do "ipkg install videodev"
i did "ipkg install kmod-videodev"

Also , i could not do "cat "videodev" >> /etc/modules"
and cat "spca5xx_lite" >> /etc/modules". I get file not found.

i could not see /dev/v4l/videodev
spcacat fails with "error opening dev/video0"
thanks for help.

dmesg is as follows;

root@OpenWrt:~# dmesg
CPU revision is: 00029006
Primary instruction cache 16kB, physically tagged, 2-way, linesize 16 bytes.
Primary data cache 16kB, 2-way, linesize 16 bytes.
Linux version 2.4.30 (mbm@reboot) (gcc version 3.4.4 (OpenWrt-1.0)) #1 Mon Nov 6 17:35:21 PST 2006
Setting the PFC value as 0x15
Determined physical RAM map:
memory: 02000000 @ 00000000 (usable)
On node 0 totalpages: 8192
zone(0): 8192 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
CPU: BCM4704 rev 8 at 264 MHz
Using 132.000 MHz high precision timer.
Calibrating delay loop... 263.78 BogoMIPS
Memory: 30420k/32768k available (1464k kernel code, 2348k reserved, 104k data, 84k init, 0k highmem)
Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
Checking for 'wait' instruction...  unavailable.
POSIX conformance testing by UNIFIX
PCI: Fixing up bus 0
PCI: Fixing up bridge
PCI: Setting latency timer of device 01:00.0 to 64
PCI: Fixing up bus 1
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Registering mini_fo version $Id$
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
Squashfs 2.1-r2 (released 2004/12/15) (C) 2002-2004 Phillip Lougher
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0xb8000300 (irq = 3) is a 16550A
ttyS01 at 0xb8000400 (irq = 0) is a 16550A
b44.c:v0.93 (Mar, 2004)
PCI: Setting latency timer of device 00:01.0 to 64
eth0: Broadcom 47xx 10/100BaseT Ethernet 00:18:f3:70:5e:93
PCI: Setting latency timer of device 00:02.0 to 64
eth1: Broadcom 47xx 10/100BaseT Ethernet 40:10:18:00:00:2d
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
Amd/Fujitsu Extended Query Table v1.3 at 0x0040
number of CFI chips: 1
cfi_cmdset_0002: Disabling fast programming due to code brokenness.
Flash device: 0x800000 at 0x1c000000
bootloader size: 262144
Physically mapped flash: Filesystem type: squashfs, size=0xda5f3
Creating 5 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x007f0000 : "linux"
0x000bf400-0x001a0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
0x007f0000-0x00800000 : "nvram"
0x001a0000-0x007f0000 : "OpenWrt"
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
ip_conntrack version 2.1 (5953 buckets, 5953 max) - 332 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
NET4: Ethernet Bridge 008 for NET4.0
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 84k freed
Algorithmics/MIPS FPU Emulator v1.5
diag: Detected 'ASUS WL-500g Premium'
Probing device eth0: found!
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
jffs2.bbc: SIZE compression mode activated.
PCI: Setting latency timer of device 01:02.0 to 64
PCI: Enabling device 01:02.0 (0004 -> 0006)
eth2: Broadcom BCM4318 802.11 Wireless Controller 3.90.37.0
Linux video capture interface: v1.00
BFL_ENETADM not set in boardflags. Use force=1 to ignore.
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Enabling device 01:03.0 (0000 -> 0001)
uhci.c: USB UHCI at I/O 0x100, IRQ 2
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Enabling device 01:03.1 (0000 -> 0001)
uhci.c: USB UHCI at I/O 0x120, IRQ 2
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Enabling device 01:03.2 (0000 -> 0002)
ehci_hcd 01:03.2: PCI device 1106:3104
ehci_hcd 01:03.2: irq 2, pci mem c016b000
usb.c: new USB bus registered, assigned bus number 3
EHCI: Enabling VIA 6212 workarounds
ehci_hcd 01:03.2: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29/2.4
hub.c: USB hub found
hub.c: 4 ports detected
device eth0 entered promiscuous mode
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
vlan0: add 01:00:5e:00:00:01 mcast address to master interface
vlan0: dev_set_promiscuity(master, 1)
vlan0: dev_set_allmulti(master, 1)
device eth2 entered promiscuous mode
eth2: attempt to add interface with same source address.
br0: port 2(eth2) entering listening state
br0: port 1(vlan0) entering listening state
br0: port 2(eth2) entering learning state
br0: port 1(vlan0) entering learning state
br0: port 2(eth2) entering forwarding state
br0: topology change detected, propagating
br0: port 1(vlan0) entering forwarding state
br0: topology change detected, propagating
vlan1: add 01:00:5e:00:00:01 mcast address to master interface
hub.c: new USB device 01:03.0-1, assigned address 2
usb.c: USB device 2 (vend/prod 0x46d/0x8a6) is not claimed by any active driver.
usb.c: registered new driver spca5xx
spca_core.c: spca5xx driver 00.57.06LE registered
usb.c: USB disconnect on device 01:03.0-1 address 2
hub.c: new USB device 01:03.0-1, assigned address 3
usb.c: USB device 3 (vend/prod 0x46d/0x8a6) is not claimed by any active driver.


--
Prabhu

Offline

 

#4 2007-02-12 00:19:43

Oconnor
Member

Registered: 2005-07-29
Posts: 161

Re: Webcam on Asus WL500G

Yes it is possible. Macsat has a good tutorial for webcams: Spca5xx-LE WebCam.
I already tryed that tutorial succesfully with openwrt RC5. But that spca5-driver is very old and not realy stable.

Offline

 

#5 2007-02-12 02:56:50

prabhu_g
Member

Registered: 2007-02-11
Posts: 3

Re: Webcam on Asus WL500G

Thank you, i will try it with RC5 , i was facing problems rc6.

Offline

 

#6 2007-02-12 06:27:02

prabhu_g
Member

Registered: 2007-02-11
Posts: 3

Re: Webcam on Asus WL500G

same errors as with rc6. now i am using rc5.

Linux video capture interface: v1.00
usb.c: registered new driver spca5xx
spca_core.c: spca5xx driver 00.57.06LE registered
usb.c: USB disconnect on device 01:03.0-2 address 2
hub.c: new USB device 01:03.0-2, assigned address 3
usb.c: USB device 3 (vend/prod 0x46d/0x8a6) is not claimed by any active driver.
root@OpenWrt:~#

root@OpenWrt:~# logread -f
Jan  1 00:01:25 (none) kern.info kernel: usb.c: USB disconnect on device 01:03.0-2 address 2
Jan  1 00:01:33 (none) kern.info kernel: hub.c: new USB device 01:03.0-2, assigned address 3
Jan  1 00:01:33 (none) kern.warn kernel: usb.c: USB device 3 (vend/prod 0x46d/0x8a6) is not claimed by any active driver.

still the same problem sad 
in the hardware supported table the device id is 0x08a6 but i get 0x8a6.
there is a zero missing. will that be the problem?
please help me out.

thanks

Offline

 

#7 2007-02-12 07:20:19

keitsi
Member

From: Helsinki, Finland
Registered: 2005-10-23
Posts: 73

Re: Webcam on Asus WL500G

If you have Asus WL-500gP or some router with USB, you could use gphoto2 and an older digital camera plugged to an USB port...
http://lnx.manoweb.com/wifi/webcam/

Offline

 

#8 2007-02-12 12:57:35

Oconnor
Member

Registered: 2005-07-29
Posts: 161

Re: Webcam on Asus WL500G

prabhu_g wrote:

Jan  1 00:01:33 (none) kern.warn kernel: usb.c: USB device 3 (vend/prod 0x46d/0x8a6) is not claimed by any active driver.

still the same problem sad 
in the hardware supported table the device id is 0x08a6 but i get 0x8a6.
there is a zero missing. will that be the problem?
please help me out.

thanks

I guess that this is your problem, did you tried the LE version and the bigger full version? All what I did was doing this tutorial. There is an other driver "motion" you can read this thread Philips webcam and motion detection with picture sending but my webcam was not supported by motion maybe your's.

Offline

 

#9 2007-02-22 14:40:36

veekoo
Member

Registered: 2007-02-22
Posts: 10

Re: Webcam on Asus WL500G

I have been playing w. Asus WL-500GP, Whiterussian 0.9 and webcams lately.

First try: Logitech Messenger (046d/08f0): not supported on Linux

2nd try: Old Avermedia webcam. Supported by ov51x -drivers. I installed "motion", filled jffs with pictures, cleaned jffs, tuned motion. I don't need live streaming, but I could easily store snapshots with motion and view those through WWW server. This round was easy and fun.

3rd round: I bought Labtec Webcam Pro, because it was supposed to be supported under Linux. spca5xx drivers recognized webcam.  Spca5xx drivers crashed when I tried 640x480 resolutin, but spca5xx_light drivers worked better. Motion doesn't work with jpeg-streaming webcams, so I had to use spcacat. I cannot control camera at all, so outdoor pictures are either almost black or almost all white. Useless anyway. This round was not so easy and fun anymore.

4rd round (currently active): Looking for new camera. Well, actually not new, because it's very hard to find *new* camera, which is supported on pwc or ov51x drivers. I don't want another jpeg-streaming spca5xx camera, because I want to use motion. Locitech 4000 Pro from ebay seems a possible choice.

Logitech quickcam IM seems to be one of those jpeg streaming cameras, so spca5xx(_lite) + spcacat should work.

Last edited by veekoo (2007-02-22 14:41:21)

Offline

 

#10 2007-02-23 08:20:40

veekoo
Member

Registered: 2007-02-22
Posts: 10

Re: Webcam on Asus WL500G

Could anyone recommed a USB webcam for my setup

* Asus WL-500GP + Whiterussian 0.9
* 640x480 resolution
* Camera should work with "motion" (this rules out JPG streaming camera)
* Camera should work with pwc or ov51x drivers. Maybe spca5xx if camera
  works with "motion".
* Camera is easily available (= you can walk into store and buy it)

Stores are full of cameras, but it's hard to find  camera which works with
OpenWRT.

Offline

 

 

Pages: 1

Board footer

Jump to
News General Discussion (Kamikaze) Howtos and Documentation Community Releases / Announcements Hardware Hacking (un)wanted hardware General Discussion (WhiteRussian) Developers Only * Moderated NetGear DG834G GIGABYTE

Powered by PunBB
? Copyright 2002–2005 Rickard Andersson

  评论这张
 
阅读(4499)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017